Welcome to the LOOP Antenna Community!                                                                  Join and enjoy it!

We've been thinking of a community where we can all exchange ideas, opinions, or simply have a friendly chat about LOOP Antenna.

We rely on all members to help keep these discussion forums a safe place for people to share and view information.

So, please treat other community members the way you would like to be treated: be courteous and respectful, stay on topic, share your knowledge.

We will remove any post that includes personal attacks, swearing or offensive language, non-constructive criticism or falsehoods. Such a poor behavior will result in losing the community posting privileges.                                                                                                                                                                                         Thank you for your time and your help!

k6fvc
7 set 2018

Semi Auto Tune and Auto Tune for FTDX-3000D and MIDI Antenna ATU

7 commenti

Semi Auto Tune doesn't always work with my ftdx-3000d. I notice that no tuning action occurs when I press enter on the keypad unless the red tuning light is on. It's will sometimes come on when changing frequencies, and other times it will not.

 

Auto Tune does not do anything at all.

 

I have an FTDX-3000D connected to the ATU with a RS-232 straight through 9 pin cable. On my FTDX-3000D are; 037 CAT-RS232C, 038 CAT RATE - 38400bps (tried different rates), CAT TIME OUT TIMER (have tried various) - 1000ms, and CAT RTS - Disable (tried enable). On the ATU the settings are; Semi-Auto, CAT MODE, Baud Rate 38400bps.

 

I have a MIDI antenna (newly installed). My Version numbers are Board 1.06.0470 and Firmware V3.22 - which all looks like the latest.

 

Any help is appreciated.

 

Fred, K6FVC

adrian04
7 set 2018

Perhaps I can help.

If you examine your FTDX-3000 CAT manual, you will find the actual pin connections of your RS-232 port on the rear of your transceiver. The reason you are not getting anything to work is that if you are using a straight-through cable, then this is incorrect. The correct connections are:

 

FTDX-3000 SIGNAL NAME CIRO_MAZZONI SIGNAL NAME

2 TX Data ------> 3 RX Data

3 RX Data <------ 2 TX Data

5 GROUND 5 GROUND

7 RTS (Ready To Send) N/A

8 CTS (Clear To Send) N/A

 

Using the menu, set menu item 037 to RS-232, menu item 038 to 9600 Baud, menu item 039 to 3000 mSec, and menu item 040 to Disable. There is no benefit to using port speeds higher than 9600 Baud, indeed, even 4800 Baud is more than fast enough.

 

Your transceiver uses what is called the ASCII Command Set, and the C-M controller is constantly sending the VFO-A frequency query commend. This command is: FA; your transceiver will respond with, for example, FA12345670; to indicate that VFO-A is tuned to 12.345670 MHz. Using a terminal program and a suitable USB to RS-232 convertor you could easily verify that this is happening.

 

Since the C-M controller does not use either the CTS or RTS status lines, you need to ensure that you have indeed disabled these. You may need to jumper pin 7 to pin 8 on the DB-9 connector on the back of your transceiver, although this is not normally required.

73, Adrian, 5B4AIY

k6fvc
7 set 2018

Awesome!

 

I will do that’s tonight report back. Seems easy enough. Swap 2 and 3 then disable 7 and 8. Settings should be a snap.

 

Thank You!

k6fvc
8 set 2018

After fiddling without success to implement the suggested cabling and a full null-modem cable, I reverted back to a straight through RS-232, 4800 bps, and 1000ms delay. Cut 2 feet off my 10 foot cable and the ATU is working good now in both auto and semi-auto. 3-20 second delay with auto-tuning and 2-10 second delay for red tune light for semi-auto tune. Although the information above is greatly appreciated, it did not apply to my installation.

 

I would like to offer a suggestion to add the rs-232 cable spec for CAT to the manual.

adrian04
8 set 2018

Now that is a surprise, nevertheless, you can't argue with success! It is always preferable to use the shortest cables for RS-232 communications, as cable capacitance will certainly degrade the data. Reducing the speed also helps, as you have discovered. In the semi-auto mode the red LED will illuminate whenever the loop frequency and the transceiver frequency differ by more than a certain amount. The effect is most notable on the lower frequency bands, as the actual bandwidth of the loop is narrow, and any tuning error is more noticeable. You can easily verify by experiment. Tune the transceiver to, for example, 7150kHz and tune the loop to the same frequency. Now slowly tune the transceiver and note when the red LED starts to flash, and note the difference in frequency. Now tune the transceiver to, for example, 28,300kHz, and again retune the loop. Now slowly tune the transceiver and note the frequency where the LED starts to flash again, and note the difference, you will find that you can tune off the loop's resonant frequency by quite a large amount at the higher frequencies. In my case a semi-auto retune takes about 2 to 15 seconds depending upon the frequency shift, so your timings are well within the expected range.

73, Adrian, 5B4AIY

k6fvc
8 set 2018

Adrian,

 

Thank you so much for sharing your wisdom. I appreciate it! Last night I found what you have described. I just think that a 10 foot cable just had too much loss. I have a factory 6 ft cable on the way and suspect that may help a little bit more. Having the right expectations is key too. Knowing that I need to wait 2-15 seconds is important - as for me, I now know the system is functioning as expected.

 

Thank You again!

73, Fred K6FVC

adrian04
29 set 2018

Hi, Fred,

I was puzzled by the fact that your RS-232 cable is straight through, and I found that I had mislabelled the transmit and receive data lines. This came about because I was using the labelling in the Icom CT-17 schematic, which turns out to be incorrect. My apologies for this. I have posted the correct connections on this website, and I hope I have not caused too much confusion. You may also be interested in my somewhat humorous experience with regard to an intermittent SWR problem which I only solved when I moved house and discovered a mouse nest in the mounting box of the loop. I wonder what he thought of the RF when I transmitted!

73 Adrian, 5B4AIY

k6fvc
10 dic 2018

Anxiously awaiting new ATU FW to address the auto-tune delay issue for Yaesu as well as other enhancements.

 

ETA?

I post più recenti

Ciro Mazzoni Radiocomunicazioni

 

via Bonincontro, 18

37139 Verona -ITALIA-

info@ciromazzoni.com

Tel: +39 0458903104 Fax: +39 0458902633

 

P.IVA 03063020238

© 2014 created by Sergio Mazzoni